java:无法访问org.springframework.boot.SpringApplication的解决方法

 

报错信息如下:

java: 无法访问org.springframework.boot.SpringApplication
错误的类文件: /C:/Users/11848/.m2/repository/org/springframework/boot/spring-boot/3.0.0/spring-boot-3.0.0.jar!/org/springframework/boot/SpringApplication.class
类文件具有错误的版本 61.0, 应为 52.0
请删除该文件或确保该文件位于正确的类路径子目录中。

 

解决办法:

这个错误的原因是idea默认的spring-boot-starter-parent版本是3.0,改成2.7.6或者更低版本就可以了

 

合并集合

一共有 n 个数,编号是 1∼n,最开始每个数各自在一个集合中。

现在要进行 m 个操作,操作共有两种:

M a b,将编号为 a 和 b 的两个数所在的集合合并,如果两个数已经在同一个集合中,则忽略这个操作;

Q a b,询问编号为 a 和 b 的两个数是否在同一个集合中;

输入格式

第一行输入整数 n 和 m。

接下来 m 行,每行包含一个操作指令,指令为 M a b 或 Q a b 中的一种。

输出格式

对于每个询问指令 Q a b,都要输出一个结果,如果 a 和 b 在同一集合内,则输出 Yes,否则输出 No。

每个结果占一行。

数据范围

1≤n,m≤105

输入样例:

4 5
M 1 2
M 3 4
Q 1 2
Q 1 3
Q 3 4

输出样例:

Yes
No
Yes

 

提交代码

#include<iostream>
using namespace std;

const int N = 100010;
int n, m;
int p[N];

int find(int x)                 // 找到x的祖先节点
{
  if (p[x] != x) p[x] = find(p[x]);
  return p[x];
}

int main()
{
  scanf("%d %d", &n, &m);
  for (int i = 1; i <= n; ++i) p[i] = i;
  
  while (m--)
  {
      char op;
      int a, b;
      scanf (" %c%d%d", &op, &a, &b);
      if (op == 'M') p[p[find(a)]] = find(b);        // 让a的祖先节点指向b的祖先节点
      else
      {
          if (find(a) == find(b)) puts("Yes");
          else puts("No");
      }
  }
  return 0;
}
import java.io.*;

public class Main
{
  static int N = 100010;
  static int n, m;
  static int [] p = new int [N];
  
  static int find(int x)
  {
      if (p[x] != x) p[x] = find(p[x]);
      return p[x];
  }
  
  public static void main(String[] args) throws IOException
  {
      BufferedReader reader = new BufferedReader(new InputStreamReader (System.in));   
      String [] str = reader.readLine().split(" ");
      n = Integer.parseInt(str[0]);
      m = Integer.parseInt(str[1]);
      
      for (int i = 1; i <= n; ++ i) p[i] = i;
      while (m -- > 0)
      {
          String op;
          int a, b;
          str = reader.readLine().split(" ");
          op = str[0];
          a = Integer.parseInt(str[1]);
          b = Integer.parseInt(str[2]);
          if (op.equals("M")) p[find(a)] = find(b);
          else 
          {
              if (find(a) == find(b)) System.out.println("Yes");
              else System.out.println("No");
          }
      }
  }
}

 

总结

关于java:无法访问org.springframework.boot.SpringApplication解决的文章就介绍至此,更多相关java无法访问org.springframework.boot.SpringApplication内容请搜索编程宝库以前的文章,希望以后支持编程宝库

首先创建一个springboot项目接着​当运行DemoApplication的时候控制台报错我们根据报错提示 知道了是jdk版本的问题​打开文件 点项目结构 - > ...